Erro no deploy de aplicção Node.js

Bom dia, estou como o seguinte problema, registerei o dominio pela Umbler e fiz o deploy seguindo os passos. Configurei o packjson como sugureido pela umbler e também coloquei na porta 3000. Ao fazer o deploy o build ocorre normalmente, o Site da umbler indica que está fazendo o deploy, entretanto os espaços disnoniveis para minha aplicação não se alteram, como se não tivesse nada e meu site fica com o erro 503.

Os log me parecem ok tbm:

2019-09-26T13:31:37.2044258Z: NPM detected!
2019-09-26T13:31:43.0534008Z: npm WARN index.js@1.0.0 No repository field.
2019-09-26T13:31:43.0534457Z: 
2019-09-26T13:31:43.0554554Z: added 50 packages from 37 contributors and audited 126 packages in 3.141s
2019-09-26T13:31:43.0569856Z: found 0 vulnerabilities
2019-09-26T13:31:43.0570353Z: 
2019-09-26T13:31:43.0781806Z: Build OK

Alguém sabe que procesedimento fazer?

Oi @lucas_paris!

Pode dar uma olhada nos logs do site no App da Umbler e ver qual erro é gerado?

Eu editei a publicação, seria o mesmo log que coloquei nela?

@lucas_paris talvez esses sejam os logs de deploy. Os logs da aplicação vão estar no menu principal do App, bem aqui:

Pode conferir nessa opção?

Olá, olhei os logs e perante alguns erros eu resolvi criar uma nova aplicação para hospedar, bem básica e acabei conseguindo, porem coonforme fui refazendo o projeto o host caiu e os logs foram os seguintes:

Sep 26 19:39:59 npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Sep 26 19:39:59 npm ERR! Failed at the teste1@1.0.0 start script.
Sep 26 19:39:59 npm ERR!
Sep 26 19:39:59 npm ERR! Exit status 1
Sep 26 19:39:59 npm ERR! teste1@1.0.0 start: node app.js
Sep 26 19:39:59 npm ERR! errno 1
Sep 26 19:39:59 npm ERR! code ELIFECYCLE
Sep 26 19:39:59 at Module._compile (internal/modules/cjs/loader.js:689:30)
Sep 26 19:39:59 at Object. (/usr/src/app/app.js:5:14)
Sep 26 19:39:59 at require (internal/modules/cjs/helpers.js:20:18)
Sep 26 19:39:59 at Module.require (internal/modules/cjs/loader.js:637:17)
Sep 26 19:39:59 at Function.Module._load (internal/modules/cjs/loader.js:530:3)
Sep 26 19:39:59 at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
Sep 26 19:39:59 at Module.load (internal/modules/cjs/loader.js:599:32)
Sep 26 19:39:59 at Object.Module._extensions…js (internal/modules/cjs/loader.js:700:10)
Sep 26 19:39:59 at Module._compile (internal/modules/cjs/loader.js:689:30)
Sep 26 19:39:59 at Object. (/usr/src/app/models/Post.js:1:74)
Sep 26 19:39:59 at require (internal/modules/cjs/helpers.js:20:18)
Sep 26 19:39:59 at Module.require (internal/modules/cjs/loader.js:637:17)
Sep 26 19:39:59 at Function.Module._load (internal/modules/cjs/loader.js:530:3)
Sep 26 19:39:59 at tryModuleLoad (internal/modules/cjs/loader.js:538:12)
Sep 26 19:39:59 at Module.load (internal/modules/cjs/loader.js:599:32)
Sep 26 19:39:59 at Object.Module._extensions…js (internal/modules/cjs/loader.js:700:10)
Sep 26 19:39:59 at Module._compile (internal/modules/cjs/loader.js:689:30)
Sep 26 19:39:59 at Object. (/usr/src/app/models/db.js:5:19)
Sep 26 19:39:59 at new Sequelize (/usr/src/app/node_modules/sequelize/lib/sequelize.js:324:20)
Sep 26 19:39:59 at new MysqlDialect (/usr/src/app/node_modules/sequelize/lib/dialects/mysql/index.js:14:30)
Sep 26 19:39:59 at new ConnectionManager (/usr/src/app/node_modules/sequelize/lib/dialects/mysql/connection-manager.js:28:21)
Sep 26 19:39:59 at ConnectionManager._loadDialectModule (/usr/src/app/node_modules/sequelize/lib/dialects/abstract/connection-manager.js:81:15)
Sep 26 19:39:59 Error: Please install mysql2 package manually
Sep 26 19:39:59
Sep 26 19:39:59 ^
Sep 26 19:39:59 throw new Error(Please install ${moduleName} package manually);
Sep 26 19:39:59 /usr/src/app/node_modules/sequelize/lib/dialects/abstract/connection-manager.js:81

O projeto funciona normalmente em localhost

Resolvi o problema, Obrigado pela atenção!

1 Curtida

Que ótimo, Lucas! Qual era o problema?