Node js não funciona

Fiz o deploy com sucesso, no entanto recebo código 503 quando tento acessar a aplicação, o log n me mostra nenhum erro, nada que me indique o que pode estar errado.

A porta está configurada corretamente para 3000 como indicado, o package.json tem um script para o start da aplicação. Realmente não sei o que fazer…

Li a documentação e fiz um novo deploy evitando usar o nodemon (entretanto ainda era necessário usar o babel).

esse é o meu packager.json:

    {
  "name": "hambre",
  "version": "1.0.0",
  "description": "",
  "main": "app.js",
  "scripts": {
    "start": "node app.js",
    "test": "echo \"Error: no test specified\" && exit 1",
    "postinstall": "babel-node app.js"
  },
  "keywords": [],
  "author": "",
  "license": "ISC",
  "dependencies": {
    "bcrypt": "^3.0.6",
    "cors": "^2.8.5",
    "express": "^4.17.0",
    "jsonwebtoken": "^8.5.1",
    "mongoose": "^5.5.11",
    "multer": "^1.4.1",
    "path": "^0.12.7"
  },
  "devDependencies": {
    "babel-cli": "^6.26.0",
    "babel-preset-es2015": "^6.24.1"
  }
}

esse é o log do deploy:

2019-10-18T14:20:11.4167039Z: Yarn detected!
2019-10-18T14:20:12.3199666Z: yarn install v1.9.4
2019-10-18T14:20:12.4569087Z: [1/4] Resolving packages...
2019-10-18T14:20:12.8262449Z: [2/4] Fetching packages...
2019-10-18T14:20:12.8514402Z: (node:7) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
2019-10-18T14:20:20.015424Z: info fsevents@1.2.9: The platform "linux" is incompatible with this module.
2019-10-18T14:20:20.0154879Z: info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation.
2019-10-18T14:20:20.0267289Z: [3/4] Linking dependencies...
2019-10-18T14:20:22.6215355Z: [4/4] Building fresh packages...
2019-10-18T14:20:24.9890672Z: $ babel-node app.js
2019-10-18T14:20:28.546445Z: (node:62) DeprecationWarning: current Server Discovery and Monitoring engine is deprecated, and will be removed in a future version. To use the new Server Discover and Monitoring engine, pass option { useUnifiedTopology: true } to the MongoClient constructor.
2019-10-18T14:20:29.5651784Z: (node:62) DeprecationWarning: collection.ensureIndex is deprecated. Use createIndexes instead.

as duas ultimas linhas do log mostram que a aplicação foi executada, no entanto continuo recebendo 503, e requisições do Postman n são respondidas.

Olá bom dia tudo bem? O erro 503 persiste? Não achei nenhum site vinculado a sua conta, me informe por aqui se o problema persiste e qual site está ocorrendo o erro 503 vou verificar o mais rápido possível, desculpe-nos pela demora no retorno do seu chat.

Isso aconteceu comigo também e resolvi fazendo um “gol de mão” na verdade o que acontece é que ele não baixa todas as dependências do package.json não sei o porquê, então eu simplesmente fui no gerenciador de arquivos exclui a minha pasta node_modules e fiz upload da minha própria máquina, eu sei isso é chato, mas foi a única forma que eu consegui achar uma solução.

espero ter ajudado! :grin:

1 Curtida