Página .php não abre na área de teste da Umbler

Bom dia!
Gostaria de uma orientação de como resolver o seguinte problema; mas antes preciso informar que sou desenvolvedor iniciante e, pelo que entendi até o momento do problema, estou com erro no meu código para abrir uma página .php na internet setada por uma outra página .php, acessando a Umbler.
Vamos lá:
O meu domínio é magsystems.com.br. Não é registrado na Umbler, porém, sou cliente da Umbler e é aonde faço meus testes.

Quero gerar uma página de orçamento - “rel_orcamento_html.php”, partindo da página “rel_orcamento.php” aonde se encontra a variável do “$id” do cliente. Importante informar que tenho várias outras páginas no sistema e todas funcionam normalmente no meu site de testes “magsystems-com-br.umbler.net”. Essa é a primeira a ter problemas.

O código de busca é simples:
$id_orc = $_GET[‘id’]; (id do cliente)
$url_umbler_p4 = “http://magsystems-com-br.umbler.net/public/painel-03/”;
$html = file_get_contents($url_umbler_p4.“painel-operacional/rel/rel_orcamento_html.php?id=$id_orc”); (variável que busca orçamento)
echo $html; (deveria gerar a página do orçamento)

Entretanto, a página não abre e apresenta o seguinte erro (valer ressaltar que no servidor local - localhost - abre normalmente):

Warning: file_get_contents(http://magsystems-com-br.umbler.net/public/painel-03/painel-operacional/rel/rel_orcamento_html.php?id=5): failed to open stream: No such file or directory in /home/magsystems.com.br/public/painel-03/painel-operacional/rel/rel_orcamento.php on line 61 Call Stack: 0.0003 426056 1. {main}() /home/magsystems.com.br/public/painel-03/painel-operacional/rel/rel_orcamento.php:0 0.0230 603640 2. file_get_contents() /home/magsystems.com.br/public/painel-03/painel-operacional/rel/rel_orcamento.php:61

Observem que a página está sendo enviada para …/home/magsystems.com.br… quando deveria ser enviada para “magsystems-com-br.umbler.net

Já fiz algumas pesquisas, inclusive no suporte, mas não achei uma solução. Por favor, como resolver?
Att: Luiz Magno Pereiratexto em negrito

Oi Luiz,

Acredito que sua URL está errada, ela não deve conter /public/

Ou seja, deveria ser :

$url_umbler_p4 = “http://magsystems-com-br.umbler.net/painel-03/”;

Espero que ajude, abraços.

Obrigado pela atenção Thiago!
Mas esse teste já fiz e não faz diferença na mensagem de erro, apenas altera a retirada do /public.
Inclusive fiz testes também usando o “CURL user umbler:test-website”, com, sem, no meio, etc., mas o resultado foi a mesma mensagem de erro.
Mais uma vez obrigado! Abraços!

Opa Luiz,

Fora a questão da /public/ não vejo nada de errado. No seu exemplo inicial não tinha partes de autenticação. (Lá dentro do servidor não é necessário autenticar).

Por favor, tente usar exatamente a linha como mandei acima (sem nenhuma autenticação)

$url_umbler_p4 = “http://magsystems-com-br.umbler.net/painel-03/”;

Para abrir uma URL o parâmetro do file_get_contents tem que começar com “http”, se você começar com “umbler:test-website…” ele tentará buscar no sistema de arquivos, por isso a mensagem de erro " No such file or directory".

Abraços.

Bom dia Thiago!
Grande Thiago, funcionou sim!
Excelente! Vc está certíssimo!
Muito obrigado!
Grande abraço!

1 Curtida